Blank screen instead of Slido poll when in PowerPoint presenter mode

I’m using the Slido PowerPoint integration tool. I’ve included polls in my presentation. When I present the slideshow, once I come to a Slido poll, the screen is blank. If I advance forward to the next slide it continues the presentation. No question or information is displayed and my participants can’t see anything either.

Can you help with a solution please?



Best answer by Meggie from Slido 12 May 2022, 13:33

View original

10 replies

Userlevel 5

Hi @Daithi,

Sorry to hear the integration isn’t working properly!

Please check:

  1. whether your Slido add-in is up to date → when you open the sidebar, you might see a banner asking you to update
  2. which version of Windows you’re using → we only support Windows 10 2004 and later versions
  3. which version of PowerPoint you’re using → we only support Microsoft PowerPoint 2013 and later versions
  4. whether you’re using any other add-ins → our integration is incompatible with the Echo360, EverCam 9, HPE Content Manager, Egress and FactSet add-ins
  5. whether you’re using a company computer or network → there might be some restrictions, we can assist with communicating with your IT team

If none of these are your case, please let me know and we can investigate further :)

Hi Meggie,
Thanks for your reply.
I’m using the ‘slido for powerpoint’ integration tool. I tried to find the Slido add-in but it’s not showing for me. Maybe this is an issue?
Firstly, I’m running Windows 11. I’m using Microsoft 365 Powerpoint. I have no other add-ins at all. I’m home-based so no company network issues but I have a company slido account through webex if that is any help?
I’m still have the very same problem.


Userlevel 5

Hi @Daithi,

Thank you for checking all those! Slido for PowerPoint is the correct tool, ‘Slido add-in’ is just another name for it :) Sorry for not making that clear.

We will need to investigate this a little more. Please follow these steps:

  1. Click Start in the bottom left corner, type Slido and launch it
  2. Right-click the “S” icon in the system tray (bottom-right corner)
  3. Select Get logs
  4. Attach the generated .zip file to an email to 

🎥 Watch a how-to video

Please let me know if anything’s unclear 🤗 I have let our customer care know about your issue and they will look into it.

Userlevel 5


Just a quick update 🙂 Our QA team has been looking into this and they’ve found that this is usually caused by the add-in being out of date or company restrictions.

Please make sure that if you see a banner asking you to update, you click on ‘Update’.

If this doesn’t help, please reach out to your IT and ensure Slido is not being blocked by AntiVirus, or your company network.

I have also reported this issue to your team and shared logs. My team are hitting the same challenges on their machines. When presenting and you hit this issue, you can’t even always advance your slides and have to exit out of presentation mode and then go back in to move forward.

We are running O365 current version and Windows 11. We are a small business with no company network restrictions. 


Hope you find a solution to this as we won’t be using slido until this is resolved.


Userlevel 5

Hey @ShannonB,

Sorry to hear that! Thank you for reporting it and sharing logs, our customer care and QA teams will look into it and get back to you :)

Is there any update or resolution to this issue yet?

Userlevel 3

Hi @Daithi

Sorry to learn you are still having issues here. Did you send your logs to for the care team to investigate? 

I would recommend getting back in touch with them, they will be able to go through your issue and check that we’ve covered everything in diagnosing this. Any screenshots you can send to them of the issue would be great too. You could also connect through live chat in Slido admin. 

Let me know if you have any questions! 

I know this issue was marked as solved, but I was having the same issue with Google Slides, and discovered that the slides were coming up blank because I had rejected the Cookies. The slides were blank, and even when I presented with Slido, it wasn’t registering my users or showing my polls to the users. Once I enabled the Cookies, all was right in the world!

Userlevel 5

Hey @CoachNat,

Thank you for sharing! That’s good to know :)