Google Slides - refused to connect

  • 12 October 2021
  • 3 replies

I’ve added the add-on and the chrome extension, but when I open the sidebar or the tutorial, it says that refused to connect

3 replies

Userlevel 1

Hi @corinna!

I’m sorry you’re having an issue with opening the Slido add-on.

Could you please try the following:

The sidebar says “Drive refuses to connect”.
Solution: Log out of Chrome and log in again. Alternatively, you can try to use the same Google account in both Google Drive and Chrome.

There are some more troubleshooting tips in this article:

Please do feel free to get back in touch if this doesn’t resolve your problem :slight_smile:

I faced the same issue too. I tried it on different account, relaunch chrome, restart my laptop, and log in and out of chrome also not working. :/ 


Userlevel 5

Hey @Rachel Liew,

Sorry to hear it’s still not working after all those steps :( 

We will need to take a closer look at this. Could you please reach out to our Customer Care team at or open a chat here?

Thank you!