PowerPoint - using presenter view - slido not showing correctly

  • 20 April 2022
  • 8 replies

I am planning to use Slido for an online training session in PowerPoint.  I have two screens.  My large monitor with my webcam on the top... and my Surface Pro laptop below.  I use presenter mode on the laptop then swap that to my large screen so I can see me notes clearly and have my eyeline near the camera.  The regular slide show for what the participants see remains below on the laptop. All good usually but when I click through to the Slido poll slides the slido presentation only appears in about 2/3rd of the slide.  Anyone know how to rectify this?  I need my presenter notes on the large monitor up top as I can barely see the surface!


Best answer by Francesca 21 April 2022, 15:17

View original

8 replies

Userlevel 2

Hi @Mairi,

I definitely understand how you would need to adjust that! 

Could you please check if you’re able to change the settings in Powerpoint? Here’s how: 

Go to → File > Options > General > User Interface options and change settings to "Optimize for compatibility" 

If you’re more of a visual learner, check out this 18 second video on how to change the settings. 

It should help in adjusting the screen, so everything is layered out correctly.

Let me know how it goes!



Thanks @Francesca 

It didn’t quite work for me doing it this way…but wanted to share what did work in case others come through with a similar challenge:

I went through Display Settings and changed the resolution of the Surface to the recommend 2736 x 1824. I think I had changed the resolution in the past to work better with the monitor screen which has different dimensions to the laptop.

Thanks for your speedy advice through.  I now look forward to my presentation on Tuesday with my global client!


Userlevel 2

Hi @Mairi

Thank you for sharing! 

Fingers crossed for your presentation today 🤞

Quick Question - are you only using Slido within the WebEx application?
The reason I ask is that I have found that opening Slido in Edge or CHROME and running it from there helps not only so that I can see things more clearly (and not have to get my nose to close to the monitor) but it also creates less lag within WebEx. Everything still runs completely smoothly from the participants view point. 
An additional wonderful thing is that if someone’s computer has a glitch, and they are unable to use Slido to answer the question, you have access via Slido in Edge or CHROME to a link which you can send them as well as a question code.  Once that user has accessed the code, they are able to continue playing Slido that way the whole time! We discovered this when we had individual participants with WebEx & Slido issues. The website & code fix works almost all of the time :)   

I hope that this information is helpful - even though you already had your presentation. 

I was reading through your suggestions and tried fiddling with the suggestions from @Francesca and @Mairi. @Mairi s suggestion helped me find that my schreen resolution was set to 125%. setting that to 100% helped display Slido fully in ppt presentation mode! Yay! Thank you!

None of these solutions worked for me, but this one did: 

One workaround could be to change the monitor where presenter view should show by default:


I have tried all the suggestions above; none of them quite work for me unfortunately. What I did after converting it primary monitor, the presenter notes shown in the audience screen and then swapped the presenter view to slide shown in Display Settings on the first slide; which is not a convenient solution. I hope Slido team can address this issue.

Userlevel 2

Hello @Kemal 

would it be possible to send us an e-mail to Our Customer Care team could take a look also please include some screenshots of how it looks on your end.