Slido for PowerPoint Error: "You appear to be offline. Check your internet connection."

I followed steps from video to download add-in. As soon as I open PowerPoint, Slido icon says I’m offline. The error never goes away even if I logout of Slido and back in again. I am most definitely not offline. Has anyone seen this error before? Thanks.


16 replies

Userlevel 1

Hi @FrantzCF 

I’m sorry you have issues with the addin.

Can you create a log file and contact us at

How to get logs

  1. Click Start, type Slido and launch it
  2. Right-click the “S” icon in the system tray (bottom-right corner)
  3. Select Get logs
  4. Attach the generated .zip file to the email to


If you cannot see the Slido button in the ribbon bar, please try the steps in the I can’t see the Slido button in PowerPoint section of our guide Troubleshooting Slido for PowerPoint | Slido Community 


The support team will then be able to look into this further for you and hopefully get it resolved!

Logs are on the way

I am having the exact same issue.  Any resolution suggests?



Userlevel 2

Hi, Shane, 

Sorry to hear you’ve been experiencing the issue. 

Please send us the logs to following the steps posted above by my colleague Graeme. 

Our lovely Customer Care team will troubleshoot with you further. 

Hope that helps!



I had this same problem yesterday. I noticed that it was taking an extremely long time to integrate a new poll into my slide set.  I did this despite the red exclamation point on the Slido icon. However, when I went to Present with Slido I could only get a white screen, the poll never replaced the placeholder item. I finally uninstalled the Slido add-in and then reinstalled it. It worked and then the powerpoint presentation worked seamlessly.


Has this problem been resolved yet? I’m having the same issue.



No, this hasn’t been resolved as all. I worked with my internet provider who gave me a new modem, I worked with my employer because I store my document on Microsoft Teams and that didn’t seem to be a factor since I still had the problem after downloading the file to my computers, and Slido was very responsive in looking at my logs. Slido tells me the problem is my internet provider but I don’t think that is possible since they even gave me a new modem.  


The oddest part of this problem is that I have been successful in getting it be work if I connect to my internet providers hotspot instead of my own modem. It is a big mystery to me.

Userlevel 5

Hi @johnson596,

I’m sorry to hear you’re experiencing this issue as well!

I had a talk with our Product Manager for PowerPoint integration to make sure we’re giving you guys the right info and according to our experience, this isn’t likely a problem on Slido’s side but we’d love to check this with you!

To be able to help you as best as we can and find the root of the problem, we’re going to need your logs. 

Please follow my colleague’s, Graeme’s step-by-step guide above, and send your logs to our Customer Care team at, they’ll be able to troubleshoot this with you 1:1.


Please let me know if there’s anything else that you need help with and I hope we can resolve this for you asap! 

@johnson596 , I provided my logs to Slide Customer Care and they came back with the comment that the problem was with my internet service provider. I had the provider come out to my house, but the modem is fine, he still swiched it out and he could not find any reason to think it was at the provider level. I updated since that time to the non-Beta version add-in but that did not change anything. I wish it had, but unfortunately I think slide is still the culprit.



I am having the same problem. Installed the add-in and as soon as I open PPT, the red button with the exclamation mark is there. I am definitely not ‘off-line’. 

Userlevel 5

Hi there - 

@kwesemann @MBalsiger 

So sorry this is still an issue for you, even after sending the logs to our customer care. 


Another reason this could be happening is that depending on the network you’re connected to - your network administrator might be blocking our domains.

Alternatively, the integration can be blocked by your Microsoft administrator. It would still allow you to download it but not use it - hence the red exclamation mark. 


To make sure we resolve this issue with you faster, feel free to contact our Customer Care via chat (available 24hr/Mon-Fri) or emailing us at


Hope we can get everything up and running for you asap!

Please let me know if you have any other issues or need help with anything else.   

I have the same problem. Despite that Slido webpage tells ‘You are now logged in’ the red exclamation mark is still there, and login side panel still shows.  

I have the same problem. Internet is not a problem bcos i can access other sites from internet.


Can we launch quiz thru Slido using Outlook.

I don’t want live  quiz but Quiz to be sent in an email using slido.


Can you please help?

Userlevel 3

Hi @Rutuja

You aren’t able to host a quiz asynchronously, this is not a feature of Slido, as our quizzes are designed to deliver live. However, this sounds like a great opportunity to use our Survey to collect your feedback, which you would be able to send as an email using a permanent link. Just to note, surveys are available from all of our paid plans. 

As for the PowerPoint error you are having, could you please contact our customer care team? they will be able to assist you with troubleshooting this issue at or through our live chat in Slido admin.

Let me know if there’s anything else I can help with! 

Hello, I am having this same problem - I’ve lost two classes now, where we weren’t able to do the interaction activities - and I am definitely online. Are there any resolutions to this? I have tried rebooting and uninstalling/reinstalling slido

Userlevel 3

Hey @ThackeryBrown ,

Could you reach out to and include your log file from your computer? This will help us to see what is the issue with your integration and help troubleshoot.

How to get logs

  1. Click Start, type Slido and launch it
  2. Right-click the “S” icon in the system tray (bottom-right corner)
  3. Select Get logs
  4. Attach the generated .zip file to the email

🎥 Watch a how-to video

Let us know if you have any other questions.